Microsoft Excel:

  Таблицы и VBA. Справочник.
  Вопросы и Ответы. Советы. Примеры.
Меню Заметки | Как вывести в ячейке название месяца


Rambler's Top100


Counter CO.KZ


Вариант I.
Для достижения нужного результата можно использовать возможности, которые предоставляются при использовании собственных, т.е. пользовательских форматов. В данном случае, нас интересует только один формат, а именно ММММ

Выделите нужную ячейку или диапазон ячеек в рабочем листе, которые содержат даты (допускается выделение несмежных ячеек и диапазонов) Затем в меню Формат выберите команду Ячейки, нажмите на закладку Число и в поле Числовые форматы выберите (все форматы), в поле Тип введите ММММ и нажмите кнопку ОК.

Комментарий :
важно Этот вариант позволяет получить только визуальное представление месяца, т.е. на самом деле ячейка по-прежнему содержит дату, и эти даты могут участвовать в вычислениях.



В случае, когда необходимо получить именно текст , следует использовать следующие варианты.



Вариант II.
Для получения название месяца в виде текста можно воспользоваться стандартной функцией рабочего листа =ТЕКСТ() которая преобразует дату в текст с учётом указанного формата.

=ТЕКСТ($A$1;"ММММ")




Вариант III.
Для получения название дня можно воспользоваться стандартными функциями рабочего листа =ВЫБОР() и =МЕСЯЦ() Первая функция используется для того, чтобы возвратить одно значение из списка, используя его индекс(номер), а номер определяется с помощью второй функции, которая возвращает номер месяца (число от 1 до 12) для указанной даты.

=ВЫБОР(МЕСЯЦ($A$1);"Январь";"Февраль";"Март";"Апрель"; "Май";"Июнь";"Июль";"Август";"Сентябрь";"Октябрь";"Ноябрь";"Декабрь")




Вариант IV.
Для получения название дня в виде текста можно воспользоваться стандартными функциями рабочего листа =ИНДЕКС() и =МЕСЯЦ() Первая функция используется для того, чтобы возвратить один из элементов массива, используя его индекс(номер), а нужный номер определяется с помощью второй функции, которая возвращает номер месяца (число от 1 до 12) для указанной даты.

=ИНДЕКС({"Январь";"Февраль";"Март";"Апрель";"Май";"Июнь";"Июль"; "Август";"Сентябрь";"Октябрь";"Ноябрь";"Декабрь"};МЕСЯЦ($A$1))




Вариант V.
Тот же самый способ, что и предыдущий, но перечень всех дней недели должен располагаться в ячейках рабочего листа, в данном случае - в диапазоне B1:B12

=ИНДЕКС($B$1:$B$12;МЕСЯЦ($A$1))




Вариант VI.
Для получения название дня, можно воспользоваться уже известными стандартными функциями рабочего листа, только массив месяцев будет представлять именованную формулу.

В меню Вставка выберите пункт Имя, далее выберите команду Присвоить. В диалоговом окне Присвоение имени в поле Имя введите нужное имя, например МЕСЯЦА, а в поле Формула введите :

={"Январь";"Февраль";"Март";"Апрель";"Май";"Июнь"; "Июль";"Август";"Сентябрь";"Октябрь";"Ноябрь";"Декабрь"}


и нажмите кнопку ОК.

После создания именованной формулы, выделите нужную ячейку или диапазон ячеек в рабочем листе и введите формулу, которая будет использовать созданное Вами имя :

=ИНДЕКС(МЕСЯЦА;МЕСЯЦ($A$1))




Вариант VII.
Тот же самый способ, что и предыдущий, но именованная формула будет представлять собой не массив месяцев, а всю формулу целиком.

В меню Вставка выберите пункт Имя, далее выберите команду Присвоить. В диалоговом окне Присвоение имени в поле Имя введите нужное имя, например МЕСЯЦ_ИМЯ, а в поле Формула введите :

=ИНДЕКС({"Январь";"Февраль";"Март";"Апрель";"Май";"Июнь";"Июль"; "Август";"Сентябрь";"Октябрь";"Ноябрь";"Декабрь"};МЕСЯЦ($A$1))


и нажмите кнопку ОК.

После создания именованной формулы, выделите нужную ячейку или диапазон ячеек в рабочем листе и введите формулу, которая будет использовать созданное Вами имя :

=МЕСЯЦ_ИМЯ


Предполагается, что :
  • Ячейка A1 содержит значение даты [вариант II - VII]
  • Ячейки диапазона B1:B12 содержат названия всех месяцев года [вариант V]



    Примеры можно скачать здесь


    Вопросы, которые связаны с этой темой
  • Как выделить несмежный диапазон ячеек ?
  • Как создать свой собственный пользовательский формат ?
  • Как быстро ввести формулу сразу в несколько ячеек ?




  • Автор : Климов Павел Юрьевич
  • © 2004-2014 Климов П.Ю. Все права защищены. WebDesign & Error's Klimoff